fix CGDS usage, compilation, check usability
[epclust.git] / code / src / stage1 / CMakeLists.txt
index e69ca5d..b69602f 100644 (file)
@@ -11,9 +11,11 @@ include_directories("${CMAKE_SOURCE_DIR}")
 #ppam executable (serialize, cluster, classif)
 
 #cds
-find_path(CDS_INCLUDE_PATH "cds/cds.h")
-find_library(CDS_LIBRARY cds)
-include_directories(${CDS_INCLUDE_PATH})
+set(CGDS_INCLUDE_PATH "/usr/local/include/cgds")
+#set(CGDS_LIBRARY "/usr/local/lib/libcgds.so")
+#find_path(CDS_INCLUDE_PATH "cgds/cgds.h")
+#find_library(CGDS_LIBRARY cgds)
+include_directories(${CGDS_INCLUDE_PATH})
 
 #GSL: standard location
 find_path(GSL_INCLUDE_PATH "gsl/gsl_linalg.h")
@@ -33,8 +35,8 @@ include_directories(${LIBXML2_INCLUDE_DIR})
 file(GLOB_RECURSE ppam_src "${CMAKE_SOURCE_DIR}/*.c")
 add_executable(ppam.exe ${ppam_src})
 add_library(ppam SHARED ${ppam_src})
-target_link_libraries(ppam.exe m cds ${MPI_LIBRARIES} ${LIBXML2_LIBRARIES} ${GSL_LIBRARIES} ${CDS_LIBRARY})
-target_link_libraries(ppam m cds ${MPI_LIBRARIES} ${LIBXML2_LIBRARIES} ${GSL_LIBRARIES} ${CDS_LIBRARY})
+target_link_libraries(ppam.exe m cgds ${MPI_LIBRARIES} ${LIBXML2_LIBRARIES} ${GSL_LIBRARIES})# ${CGDS_LIBRARY})
+target_link_libraries(ppam m cgds ${MPI_LIBRARIES} ${LIBXML2_LIBRARIES} ${GSL_LIBRARIES})# ${CGDS_LIBRARY})
 
 if (MPI_COMPILE_FLAGS)
        set_target_properties(ppam.exe PROPERTIES